GoBDokumente is a macOS application
Since the idiots at Apple broke the Safari user agent string

CCBot/2.0 (https://commoncrawl.org/faq/)

under macOS Big Sur, the automatic detection of which version of GoBDokumente you need to download is temporarily suspended and you have to manually choose which version you want/need to download:

Download for macOS 10.11 - 10.15
Download for macOS 11.0 (incl. support for M1)